Le but de ce forum est d'initier les modélistes à la construction des maquettes navigantes.


    Utilisateur d'unisercom

    Partagez
    avatar
    bebert38
    Admin

    Messages : 1945
    Date d'inscription : 27/05/2010
    Age : 71
    Localisation : grenoble

    Utilisateur d'unisercom

    Message  bebert38 le Dim 20 Juin 2010 - 18:08

    papy94 Posté le 09/01/2007
    bonjour à tous
    je viens de recevoir mon unisercom que j'avais fais monter et je l'ai testé en mode tout ou rien ,alimentation 4.8volts et un micro servo


    le servo réagit bien lorsque je commute mais mon probleme est que des que je m'approche ou que je touche le fil alimentation ou le fil du servo du bout des doigts ,le servo bouge dans tous les sens ,des que je me recule ,tout redeviens normal

    _________________________________________________________________________________
    bebert38 Posté le 09/01/2007

    Bonjour,
    il y a quelque chose qui me chagrine sur le schéma du haut.
    La commande est donnée par la fermeture du contact entre entrée "commande"(bleu) et le commun (noir).
    Contact fermé, "commande" est bien à zéro; mais contact ouvert, "commande" est en l'air. Le circuit considére cette config comme un "1", mais à la moindre perturbation, il risque de changer d'état.
    A mon avis ( bien qu'ignorant en PIC), il faudrait relier le fil bleu au plus de l'alim par une résistance( 47 kohms devrait convenir)
    De façon générale, il est déconseillé de laisser une entrée en l'air. Par exemple sur un circuit 4 portes utilisé partiellement,il est de coutume de fixer un potentiel( généralement 0v) sur les entrées non utilisées. Sinon le risque d'oscillation n'est pas nul et on peut même perturber les portes utilisées.Raison de plus pour ne pas le faire pour les entrées utilisées.
    Le probléme est peut être le même pour les entrées "mode".

    Il est possible que je sois à côté du probléme, et que le PIC en question intégre des résistances de pull-up. Il faudrait voir la doc du PIC en question.

    Une question pour RCnavy, s'il passe dans le coin: Le pic est alimenté en 5 volts, d'où la diode pour chuter le tension si la batterie est de 6 volts. Qu'en est-il pour les entrées? Sont-elles protégées contre un dépassement de la tension de Vcc?

    Albert.
    _____________________________________________________________________________________
    papy94 Posté le 09/01/2007

    merci pour vos réponses

    pour info , j'utilise L'UNISERCOM comme sur la 2ieme figure (celle du bas)

    donc ont attend RCnavy pour plus d'info
    ______________________________________________________________________________________
    RcNavy Posté le 09/01/2007
    Bonsoir à tous,

    je pense comme plomb et bebert38, il s'agit pobablement du 50 Hz secteur qui réveille une entrée non référencée.

    Je ne sais plus si j'ai activé les pull-ups internes du PIC.
    Je vais vérifier.

    ...Pas la peine, ça me revient: au début, je les avais activées, mais j'ai dû les désactiver ensuite.
    En effet, je voulais utiliser le schéma déjà fait ici , mais je me suis apperçu par la suite que l'auteur de ce schéma avait mis bizarrement un pull down et non un pull-up (moi j'avais prévu des pull-ups). Du coup je me retrouvais avec un pull down et un pull-up sur la même entrée: pas bon !
    Puis, j'ai oublié de mettre un pull up externe sur l'entrée du signal (fil bleu sur le schéma) qui devenait nécessaire puisque celles en internes étaient désactivées: mea culpa !
    Je partage donc votre analyse: il manque bien un pull-up (une résistance de 10K) entre le fil bleu et le + (fil rouge).

    @ bebert38: dans le cas où la diode est montée et que le signal du récepteur est voisin de 6V, l'entrée est protégée par la diode interne de clamping (cf sujet récent).

    papy94, peux-tu monter cette résistance de pull-up de 10K est nous tenir au courant des changements ?

    PS: cette résistance de pull-up n'est pas nécessaire si UNISERCOM est commandé par la sortie d'une voie d'un récepteur RC.

    @ +,

    RC Navy.
    ______________________________________________________________________________
    papy94 Posté le 09/01/2007
    coucou

    papy94, peux-tu monter cette résistance de pull-up de 10K est nous tenir au courant des changements

    autrement si j'ai bien compris je soude un resistance de 10k entre le fil bleu (commande) et le fil rouge (alimentation 4.8 Và 6 V)
    mais avant que je fasse une betise dites moi [g]pull-up [/g] :??: c'est quoi
    j'attend de vos nouvelles avant de souder ma resistance
    vous me confirmer les couleurs


    car desolé les Ko les O ,pour moi c'est pas bien dans ma tete

    _______________________________________________________________________________
    RcNavy Posté le 09/01/2007

    Bonsoir papy94,

    Citation :
    mais avant que je fasse une betise dites moi pull-up, c'est quoi ?


    Ha oui, c'est vrai, le jargon anglo-saxon !
    pull-up: pull=tirer, up=haut, d'ou résistance qui tire vers le haut (vers le +)
    pull down: pull=tirer, down=bas, d'ou résistance qui tire vers le bas (vers le -)
    10K: 1er chiffre=marron(1), 2e chiffre=noir(0), nombre de 0=orange(3)
    C'est bien une résistance de 10 Kilo Ohm.

    ________________________________________________________________________________
    papy94 Posté le 09/01/2007

    je vous remerci beaucoups

    bonne soirée à tous

    Ps:


    le potar de reglage ,il doit faire combien ,quelle valeur environ doit-il avoir ,car c'est peut etre dans cette configuration que je vais utiliser l'UNISERCOM

    _________________________________________________________________________________
    RcNavy Posté le 09/01/2007

    ReBonsoir papy94,

    Citation :
    le potar de reglage ,il doit faire combien ,quelle valeur environ doit-il avoir ?


    Le seuil de bascule de l'entrée du PIC doit être autour de la tension d'alimentation divisée par 2 (ça n'est pas spécifié dans la datasheet du PIC). Le potard doit donc être réglé autour de 10K, puisque la résistance de pull-down vaut 10K.
    Les sondes dans l'eau ramènent une résistance en // avec le potard qui suffit à passer le seuil de l'entrée: le PIC voit alors une entrée à 1.
    Remarque: le curseur du potard doit être relié à l'une ou l'autre des bornes extrêmes du potard (ça n'apparaît pas sur le dessin).

    __________________________________________________________________________________
    francis6789 Posté le 10/01/2007

    Meilleurs Voeux papy94

    Si tu as, après, encore des soucis, je peux t'envoyer une platine de 2 Unisercom qui fonctionnent, pour faire une comparaison et trouver la cause. J'en ai en attente. Tu connais mon mail.

    A Plus.

    __________________________________________________________________________________
    papy94 Posté le 10/01/2007

    bonjours à tous

    voila ,j'ai mis ma petite resistance et pas de probléme ,90% des interferences ont bien disparus (pour les 10% restantes ,je testerais en dehors de chez moi)

    j' ai fais le test en tranpant dans l'eau les 2 fils sans mettre de resistance et cela fonctionne tres bien comme cela (normal docteur )

    Enfin grand merci à vous tous ,car honnetement j'essaye bien de compremdre mais c'est vraiment dur dur l'electronique

    Pour RcNavy
    - Peut etre mettre à jour ou modifier tes shémas sur ton site pour eviter que la qustion soit reposées X fois par des débutants

    Pour francis6789
    - Deja meilleurs voeux toi aussi ,et merci pour ta proposition ,mais comme tu vois cela fonctionne ,donc je garde ton offre bien au chaud, et si j'ai besoin je me ferais une joie de te contacter

    ___________________________________________________________________________________
    RcNavy Posté le 10/01/2007

    Bonsoir,

    papy94 a dit:

    Citation :
    Pour RcNavy
    - Peut être mettre à jour ou modifier tes schémas sur ton site pour éviter que la question soit reposées X fois par des débutants


    Voilà, c'est fait ici .

    @ +,

      La date/heure actuelle est Dim 22 Oct 2017 - 17:45